Skip to main content
← All vulnerabilities
CVE-2024-5566

Improper Privilege Management allows for access to unauthorized repository content during migration

Published
Last modified
published
Not listed in CISA KEV
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

An improper privilege management vulnerability allowed users to migrate private repositories without having appropriate scopes defined on the related Personal Access Token. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitHub GitHub Enterprise Server

    From 3.9.0 · through 3.9.16; From 3.10.0 · through 3.10.13; From 3.11.0 · through 3.11.11; From 3.12.0 · through 3.12.5; From 3.13 · through 3.13.0

References 5

docs.github.com