Skip to main content
← All vulnerabilities
CVE-2024-55638DRUPAL-CORE-2024-008BIT-DRUPAL-2024-55638GHSA-GVF2-2F4G-JQF4

Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.102, 10.2.11, 10.3.9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 7.0 before 7.102, from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9. Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so-called gadget chain presents no direct threat but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Drupal Drupal Core

    From 7.0 · fixed in 7.102; From 8.0.0 · fixed in 10.2.11; From 10.3.0 · fixed in 10.3.9

  • drupal/corePackagist

    From 8.0.0 · fixed in 10.2.11; From 10.3.0 · fixed in 10.3.9

  • drupal/corePackagist

    From 8.8.0 · fixed in 10.2.11

  • drupal/corePackagist

    From 10.3.0 · fixed in 10.3.9

  • drupal/corePackagist

    From 7.0 · fixed in 7.102

  • drupal/core-recommendedPackagist

    From 8.8.0 · fixed in 10.2.11

  • drupal/core-recommendedPackagist

    From 10.3.0 · fixed in 10.3.9

  • drupal/core-recommendedPackagist

    From 7.0 · fixed in 7.102

  • drupal/drupalPackagist

    From 8.8.0 · fixed in 10.2.11

  • drupal/drupalPackagist

    From 10.3.0 · fixed in 10.3.9

  • drupal/drupalPackagist

    From 7.0 · fixed in 7.102

References 1

drupal.org