Skip to main content
← All vulnerabilities
CVE-2024-54133GHSA-VFM5-RMRH-J26VBIT-RAILS-2024-54133

Possible Content Security Policy bypass in Action Dispatch

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.0.8.7, 7.1.5.1, 7.2.2.1, 8.0.0.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Action Pack is a framework for handling and responding to web requests. There is a possible Cross Site Scripting (XSS) vulnerability in the `content_security_policy` helper starting in version 5.2.0 of Action Pack and prior to versions 7.0.8.7, 7.1.5.1, 7.2.2.1, and 8.0.0.1. Applications which set Content-Security-Policy (CSP) headers dynamically from untrusted user input may be vulnerable to carefully crafted inputs being able to inject new directives into the CSP. This could lead to a bypass of the CSP and its protection against XSS and other attacks. Versions 7.0.8.7, 7.1.5.1, 7.2.2.1, and 8.0.0.1 contain a fix. As a workaround, applications can avoid setting CSP headers dynamically from untrusted input, or can validate/sanitize that input.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • rails rails

    From 5.2.0 · fixed in 7.0.8.7; From 7.1.0 · fixed in 7.1.5.1; From 7.2.0 · fixed in 7.2.2.1; From 8.0.0 · fixed in 8.0.0.1

  • actionpackRubyGems

    From 5.2.0 · fixed in 7.0.8.7

  • actionpackRubyGems

    From 7.1.0 · fixed in 7.1.5.1

  • actionpackRubyGems

    From 7.2.0 · fixed in 7.2.2.1

  • actionpackRubyGems

    From 8.0.0 · fixed in 8.0.0.1

References 5

GitHub · rails/rails