CVE-2024-53900GHSA-M7XQ-9374-9RVXBIT-MONGOOSE-2024-53900
Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 8.8.3, 7.8.3, 6.13.5, 5.13.23
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 2 proofs of concept on GitHub, 1 Nuclei template
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- mongoosenpm
From 8.0.0-rc0 · fixed in 8.8.3
- mongoosenpm
From 7.0.0-rc0 · fixed in 7.8.3
- mongoosenpm
From 6.0.0-rc0 · fixed in 6.13.5
- mongoosenpm
From 3.6.0-rc0 · fixed in 5.13.23