Skip to main content
← All vulnerabilities
CVE-2024-53847GHSA-6VX4-V2JW-QWQH

Trix vulnerable to Cross-site Scripting on copy & paste

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.1.9, 1.3.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • basecamp trix

    From 2.0.0 · fixed in 2.1.9; From 1.0.0 · fixed in 1.3.3

  • trixnpm

    From 2.0.0 · fixed in 2.1.9

  • trixnpm

    From 1.0.0 · fixed in 1.3.3

References 2

GitHub · basecamp/trix