Skip to main content
← All vulnerabilities
CVE-2024-48944GHSA-3V67-545X-FFC3

Apache Kylin: SSRF vulnerability in the diagnosis api

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 5.0.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api endpoint open for service. This issue affects Apache Kylin: from 5.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.kylin:kylin-ops-server

    From 5.0.0 · through 5.0.1

  • org.apache.kylin:kylin-common-serverMaven

    From 5.0.0 · fixed in 5.0.2

References 1

lists.apache.org