CVE-2024-47533GHSA-M26C-FCGH-CP6HPYSEC-2026-316
Cobbler allows anyone to connect to cobbler XML-RPC server with a known password and make changes
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.2.3, 3.3.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cobbler, a Linux installation server that allows for rapid setup of network installation environments, has an improper authentication vulnerability starting in version 3.0.0 and prior to versions 3.2.3 and 3.3.7. `utils.get_shared_secret()` always returns `-1`, which allows anyone to connect to cobbler XML-RPC as user `''` password `-1` and make any changes. This gives anyone with network access to a cobbler server full control of the server. Versions 3.2.3 and 3.3.7 fix the issue.
Timeline
- CVE published
- Record last updated
Affected versions
- cobbler cobbler
From 3.0.0 · fixed in 3.2.3; From 3.3.0 · fixed in 3.3.7
- cobblerPyPI
From 3.3.0 · fixed in 3.3.7
- cobblerPyPI
From 3.0.0 · fixed in 3.2.3